Splunk SPLK-5002 Splunk Certified Cybersecurity Defense Engineer Exam Practice Test
Splunk Certified Cybersecurity Defense Engineer Questions and Answers
The threat-hunting team has identified suspicious activity. An analyst manually creates a notable event using an event action to track the activity. How should a detection engineer ensure this activity automatically produces findings in the future?
Which practices strengthen the development of Standard Operating Procedures (SOPs)? (Choose three)
What can an engineer use to capture contextual values from a dashboard and create a drilldown to link to a new search?
A SOC ' s Incident Response Standard Operating Procedure (SOP) calls for any phishing emails containing files to be detonated in Splunk Attack Analyzer for evaluation. Which of the following can an engineer implement to gain efficiency through automation?
MITRE D3FEND is designed to compliment MITRE ' s list of adversarial tactics, techniques, and common knowledge (ATT & CK). Which tactics are associated with MITRE D3FEND in order to detect, deny, and disrupt adversarial efforts?
Based on this example image, if it is detected that a member has been added to a security-enabled local group, how many risk events will be created?

The following SPL is designed to report on a certain SOC metric. Which metric is the most likely topic for this report?
| tstats summariesonly=true earliest(_time) as _time
FROM datamodel=Incident_Management
BY " Notable_Events.Meta.rule_id "
| rename " Notable_Events.Meta.* " as " * "
| lookup update=true incident_updates_lookup rule_id OUTPUTNEW time
| search time=*
| stats earliest(_time) as create_time, min(time) as triage_time by rule_id
| eval diff=triage_time-create_time,
stat_type=if(
create_time < relative_time(now(), " -7d@d " ),
" past " ,
" current "
),
past=if(stat_type= " past " , 1, 0),
current=if(stat_type= " current " , 1, 0),
past_diff=if(stat_type= " past " , diff, 0),
current_diff=if(stat_type= " current " , diff, 0)
| stats sum(past) AS past,
sum(current) AS current,
sum(past_diff) AS past_diff,
sum(current_diff) AS current_diff
| eval past=round(past_diff/past/60),
current=round(current_diff/current/60)
| table past, current
| transpose
An automation engineer for the Wonderland SOC has configured a new asset and is getting an HTTP 403 response code. Which of the following is a possible cause of the error code?
An engineer notices that a detection is creating multiple Findings (notables) for the same potential incident. Which setting can be adjusted to reduce the number of generated findings (notables)?
When setting Common Information Model (CIM) accelerations, which parameter should be defined to set how far back in time (specified as a relative time string) the Splunk platform creates its column stores?
When creating a detection, how might an engineer ensure that all possible contextual fields about a given asset and identity are added to a risk event?
A detection engineer is using a threat defense informed strategy to define use cases. Which Splunk app would best facilitate their use case development process by cross referencing detections with the MITRE ATT & CK Framework?
Which of the following actions will allow access to a list of alert actions via the API?
Once an engineer has determined that a new detection will fire, what is the next priority for that detection?
Consider the following series of events:
4:00 GMT Detection runs for interval 3:30–4:00
4:30 GMT Detection runs for interval 4:00–4:30
4:35 GMT Event 1 occurs on an endpoint
4:45 GMT Event 1 is indexed
5:00 GMT Detection runs for interval 4:30–5:00
5:05 GMT Event 1 finding is added to ES with timestamp 4:35
5:24 GMT Event 2 occurs on an endpoint
5:30 GMT Detection runs for interval 5:00–5:30
5:35 GMT Event 2 is indexed
6:00 GMT Detection runs for interval 5:30–6:00
What is the problem with the detection schedule chosen and how can it be solved?
In the context of Splunk ' s Common Information Model (CIM), which construct ensures that events from different data sources appear in the applicable data model?
In Enterprise Security, what is the name of the threat intelligence lookup pertaining to files?
Below is an example of a Sysmon process create log. Which EventCode would be associated with this log entry?

The SOC notices over the course of an investigation there are numerous logs similar to the following:
UDP: query: reallybad.c2.com IN A response: SERVFAIL
What detection should be created to alert on this behavior for the future?
An EDR tool was recently purchased and needs to be integrated into existing Splunk SOAR playbooks. Which actions are typically associated with this type of asset?
Which Enterprise Security components provide enrichment to the Risk Framework?
Which search command was used to generate the result in the image below?

Which action improves the effectiveness of notable events in Enterprise Security?
Which of the following macro values will exclude all of the company networks if it is called from the following search?
index=firewall sourcetype=pan\:traffic NOT " company_networks "
Which of the following is not a type of metadata that can be returned by the metadata command?
During a ransomware attack, an adversary might add a default user and password in registry, modify the wallpaper, and create bulk ransomware notes across multiple machines. What is Splunk ' s method for grouping these types of detections together?
Which of the following should be the primary reference when designing a new playbook in Splunk SOAR?
Which type of correlation search reviews the events in the risk index and uses an aggregation of events impacting a single risk object to generate risk notables?
When using SOAR to automate a response with a zero trust approach, which of the following represents a valid order of operations?
When creating a new playbook to be called directly from Mission Control or Enterprise Security, which type of playbook must be used?
What is Enterprise Security ' s default way of determining the urgency of a finding (notable event)?