Pre-Summer Sale Limited Time Flat 70% Discount offer - Ends in 0d 00h 00m 00s - Coupon code: 70spcl

CrowdStrike CCSE-204 CrowdStrike Certified SIEM Engineer Exam Practice Test

Page: 1 / 6
Total 62 questions

CrowdStrike Certified SIEM Engineer Questions and Answers

Question 1

Review the log sample below:

Question # 1

What type of parser should be used to extract fields and values from this log?

Options:

A.

XML

B.

CSV

C.

JSON

D.

Key-Value

Question 2

You suspect that an API key you recently generated has been compromised.

What should you do?

Options:

A.

Regenerate a new API key directly from the platform

B.

Search the audit logs for the connector creation event and replicate it

C.

View the API key details in the platform and clone a new API key

D.

Contact CrowdStrike Support to retrieve and send the key to you

Question 3

You are reviewing logs and find that the content appears as one large block of text within the @rawstring field for incoming firewall logs. The other expected structured fields are empty.

What is the cause of this issue?

Options:

A.

The parser was incorrect

B.

The ingestion token is invalid

C.

The sink was overloaded

D.

The timestamp format is incorrect

Question 4

Which default parser would you use to parse the log event below?

Jan 15 14:22:07 host1 sshd[1234]: Failed login

Options:

A.

Key-value

B.

JSON

C.

Regex

D.

Syslog

Question 5

Which command helps visualize in real time whether sources and sinks are working properly in the Log Collector?

Options:

A.

journalctl -u logscale-collector

B.

logscale-collector monitor

C.

logscale-collector check

D.

logscale-collector --status

Question 6

Which CPS-compliant practice should be followed when a third-party field has no matching ECS field?

Options:

A.

Remove the field entirely

B.

Save it only in an external lookup table

C.

Prefix it with Vendor.

D.

Convert it to @timestamp

Question 7

The parseJson() function would be used to parse which log message format from the list below?

Options:

A.

level=debug msg="Disconnected" host=app01

B.

192.168.1.1 [192.168.1.1] - - [10/May/2024:14:23:11 +0000] "GET/index.html"

C.

{ "level": "info", "msg": "User login", "user": "john_doe" }

D.

2024-05-10T14:23:11Z INFO Service started

Question 8

Which Falcon LogScale Collector mode keeps the log source configuration stored locally on the collector host instead of centrally in Fleet Management?

Options:

A.

full

B.

central

C.

localConfig

D.

collectorOnly

Question 9

How can you enable internal logging for a specific Falcon Log Collector instance from the Fleet view?

Options:

A.

Reinstall the collector with logging enabled

B.

Edit the local configuration file

C.

Select “Manage Internal Logging” from the menu

D.

Restart the collector service with the flag “Manage Internal Logging”

Question 10

You need to import a pre-built workflow into Fusion SOAR to automate a part of your incident response process.

Which file format would you use?

Options:

A.

.CPP

B.

.JSON

C.

.PY

D.

.YAML

Question 11

What should you do with a field that is not CPS-compliant when adding it to a parser?

Options:

A.

Remove the field from the parser output

B.

Leave the field unchanged

C.

Convert the field to ECS format

D.

Prefix the field with Vendor

Question 12

In the Next-Gen SIEM Connector Dashboard, what is the maximum retention period for which you can query third-party data ingestion metrics?

Options:

A.

30 days

B.

60 days

C.

90 days

D.

180 days

Question 13

An event has the following fields:

Question # 13

Which CQL query will output the frequency of a unique set of ComputerName, UserName, CommandLine?

Options:

A.

#event_simpleName = ProcessRollup2 FileName = ssh.exe CommandLine = /\s-R\s.+\s-p/ | table([ComputerName, UserName, CommandLine]) | count()

B.

#event_simpleName = ProcessRollup2

| FileName = ssh.exe

| CommandLine = /\s-R\s.+\s-p/

| table([ComputerName, UserName, CommandLine], function=count())

C.

#event_simpleName = ProcessRollup2

| FileName = ssh.exe

| CommandLine = /\s-R\s.+\s-p/

| groupBy([ComputerName, UserName, CommandLine], function=count())

D.

#event_simpleName = ProcessRollup2 FileName = ssh.exe CommandLine = /\s-R\s.+\s-p/ | groupBy([ComputerName, UserName, CommandLine])

Question 14

What dashboard presents a view of third-party data ingestion over the past 30 days?

Options:

A.

Sensor Usage Dashboard

B.

Sensor Subscription Dashboard

C.

Falcon Flex Dashboard

D.

Next-Gen SIEM Connector Dashboard

Question 15

Which three System alerts are enabled by default in Next-Gen SIEM for third-party connectors?

Options:

A.

Alert if connector receives no data in 24 hours

Alert if connector is disconnected

Resolve alerts within 30 days

B.

Alert if daily data ingestion limit exceeded

Alert if monthly data ingestion limit is exceeded

Resolve alerts within 30 days

C.

Alert if connector is disconnected

Alert if daily data ingestion limit exceeded

Alert if monthly data ingestion limit is exceeded

D.

Alert if connector receives no data in 24 hours

Alert if daily data ingestion limit exceeded

Alert if monthly data ingestion limit is exceeded

Question 16

Which field should be used in a correlation rule when detections must be based on the original event occurrence time?

Options:

A.

@ingesttimestamp

B.

@timestamp

C.

@rawstring

D.

@id

Question 17

You notice that the format of incoming logs suddenly changes from JSON format to key-value pairs during log collection.

What action would you take to parse the data correctly?

Options:

A.

Use a multi-source configuration with different parsers per source

B.

Switch to fleet mode and monitor the logs

C.

Restart the log collector in debug mode

D.

Disable parsing entirely

Question 18

You are onboarding a log source that includes a timestamp with a different timezone.

How should you address any time parsing errors that occur?

Options:

A.

Clone the parser and manually apply the timezone parameter

B.

Adjust the log source to reflect the correct timezone before sending logs

C.

Clone the parser and change the timestamp field name

D.

Clone the parser and drop the timestamp field, use ingesttimestamp instead

Page: 1 / 6
Total 62 questions